В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lolkek142
lolkek142
23.02.2022 17:48 •  Информатика

Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в другой файл. учтите, что таких чисел может вообще не быть. (язык программирования паскаль)

Показать ответ
Ответ:
Alin4ikVP
Alin4ikVP
23.07.2020 10:20
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,'dan.txt'); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max<a) then
   max:=a;
 end;
 close(f);
 assign(f,'res.txt');
 rewrite(f);
 if max=0 then writeln(f,'чётных положительных чисел нет')
  else
   writeln(f,'min среди чётных положительных чисел =',min, chr(13),
      'max среди чётных положительных чисел нет',max);
  close(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота