В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
handball230912
handball230912
26.08.2022 04:44 •  Информатика

Напишите программу, которая находит минимальное и максимальное значение, записанное в массив.Наполнение массива, поиск минимального и максимального значений оформить в процедуры это очень важное задание.

Показать ответ
Ответ:
polina1336
polina1336
05.09.2020 04:25
Var     
q: Single; // Результат. Если число будет больше, то указать Double
i: Single; // Число из которого необходимо получить результат. Если число будет больше, то указать Double
p: Single; // Процент. Если процент будет всегда целым числом, то указать Byte
begin 
writeln('Введите число => '); 
read(i); 
writeln('Введите процент, который хотите расcчитать из введенного числа => ');   
read(p); 
while p < 0 do
begin     
writeln('Процент не может быть меньше нуля, введите новое значение => ');   
read(p);   
end; 
q:=(i / 100) * p; 
writeln('Ваш результат из числа => ', i, ', ', p, '% = ', q);
end.
0,0(0 оценок)
Ответ:
tolkacheva2005
tolkacheva2005
09.08.2022 16:08

#include <iostream>

#include <cmath>

#include <algorithm>

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

signed main() {

  ll n = 8;

  ll a[n];

  ll sum = 0;

  for(ll i = 0; i < n; i++){

      cin >> a[i];

      if(a[i] % 6 == 0 && a[i] % 4 == 0)

          sum += a[i];

  }

  cout << sum << "\n";

  n = 12;

  sum = 0;

  ll b[n];

  for(ll i = 0; i < n; i++){

      cin >> b[i];

      if(b[i] % 5 == 0)

          sum++;

  }

  cout << sum;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота