В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dianavoronina4545
dianavoronina4545
03.09.2021 11:32 •  Информатика

Напишите программу, которая находит минимальный и максимальный элементы из элементов матрицы с четными положительными значениями и их индексы. учтите, что таких элементов в матрице может и не быть

Показать ответ
Ответ:
12345qwertgechjih
12345qwertgechjih
31.08.2020 01:57
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var m:=ReadInteger('Число строк=');
  var n:=ReadInteger('Число стролбцов=');
  var a:=MatrixRandom(m,n,-99,99);
  var imax:=-1; var jmax:=0;
  var imin:=0; var jmin:=0;
  var min:=100; var max:=-100; // больше большего, меньше меньшего
  for var i:=0 to m-1 do begin
    for var j:=0 to n-1 do begin
      Write(a[i,j]:4);
      if (a[i,j]>0) and (a[i,j] mod 2=0) then begin
        if a[i,j]<min then begin imin:=i; jmin:=j; min:=a[i,j] end;
        if a[i,j]>max then begin imax:=i; jmax:=j; max:=a[i,j] end
        end
      end;
    Writeln
    end;
  if imax<>-1 then begin
    Writeln('Минимальный четный положительный элемент A[',
        imin+1,',',jmin+1,']=',a[imin,jmin]);
    Writeln('Максимальный четный положительный элемент A[',
      imax+1,',',jmax+1,']=',a[imax,jmax])
    end
  else
    Writeln('В массиве нет положительных четных элементов')
end.

Тестовое решение
Число строк= 5
Число стролбцов= 8
 -59  98  55 -92 -98  68   5 -82
  63  49  41   7  51  22  55  -4
 -78  42 -35 -60  -6 -15 -34 -28
 -14  55 -44  22  74 -50 -98  85
  50   2  65  39 -47 -59  -7 -87
Минимальный четный положительный элемент A[5,2]=2
Максимальный четный положительный элемент A[1,2]=98
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота