В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Matveystori
Matveystori
16.05.2023 12:08 •  Информатика

Напишите программу, которая находит среднее арифметическое всех четных положительных чисел, записанных в файле в столбик, и выводит результат в другой файл. Учтите, что таких чисел может вообще не быть.

Показать ответ
Ответ:
ksyushay02
ksyushay02
27.07.2020 21:01

Объяснение:

program Randomizer;

const

  RndLimit = 10000;

var

  x, SumX : integer;

begin

SumX := 0;

Repeat x := Random(RndLimit) until x > 999;

writeln ('Random X= ', x);

SumX := SumX + (x div 1000) + (x mod 1000 div 100) + (x mod 1000 mod 100 div 10) + (x mod 1000 mod 100 mod 10);

writeln ('Sum = ', SumX);

end.

запускаем

Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64

Copyright (c) 1993-2012 by Florian Klaempfl and others

Target OS: Linux for x86-64

Compiling main.pas      

Linking a.out            

21 lines compiled, 0.1 sec

Random X= 5488            

Sum = 25

0,0(0 оценок)
Ответ:
zaper886
zaper886
29.04.2021 23:40

ответ:Сенкан - это стихотворение, состоящее из пяти строк. 

Слово "сенкан" происходит от французского слова «пять» и обозначает стихотворение в пять строк. 

1. первая строка должна содержать слово, которое обозначает тему (конечно, это существительное) 

2. Вторая строка - это описание темы, состоящий из двух слов (два прилагательного) 

3. Третья строка называет действие, связанное с темой, и состоит из трех слов (обычно это глаголы). 

4. Четвертая строка является фразой, которая состоит из четырех слов и выражает отношение к теме, чувства по поводу обсуждаемого. 

5. Последняя строка состоит из одного слова - синонима к первому слову, в нем выражается сущность темы, будто делается итог.

Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота