В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
илья20067
илья20067
28.07.2022 20:04 •  Информатика

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: pascal abc.

Показать ответ
Ответ:
ПетяВасечкин485
ПетяВасечкин485
17.09.2020 23:27
Const
  n = 25;
var
  a: array[1..n] of integer;
  i, s: integer;
begin
  Writeln('Введите элементы массива');
  s := 0;
  for i := 1 to n do
  begin Read(a[i]); s := s + a[i] end;
  Writeln('Среднее значение элементов массива равно ', s/n)
end.
0,0(0 оценок)
Ответ:
Zavaw
Zavaw
17.09.2020 23:27
Var A:array[1..25] of Integer;
i:integer;
S:real;
begin
Readln(N);
For i:=1 to 25 do
Readln(A[i]);
For i:=1 to 25 do
S:=S+A[i];
S:=S/25;
Writeln(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота