В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2012schtv
2012schtv
19.08.2022 20:10 •  Информатика

Напишите программу, которая находит в массиве целых чисел количество элементов, равных заданному значению x . возможно решать по-разному, например, использовать дополнительные массивы или даже не использовать массивы совсем. главное - вывести правильный ответ. вы должны ввести полный текст программы на java: необходимые импорты, один public класс в пакете по умолчанию (в коде отсутствует подстрока package), функцию комментарии на кириллице не разрешены. ввод осуществляется с консоли, вывод - на консоль. программа должна работать точно по протоколу, который показан в примерах. например, нельзя выводить ничего лишнего, скажем, фразу "введите n". входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x. гарантируется, что данные корректны и n < 10001. выходные данные программа должна вывести одно целое число – количество элементов массива, равных x . for example: } на java

Показать ответ
Ответ:
evazorina1
evazorina1
10.04.2020 23:47

#include <iostream>

using namespace std;

int main()

{

setlocale(0,"");

   cout<<"Введите размеры";

   int n,m;

   cin>>m>>n;

   int** a = new int*[m];

   for (int i = 0; i<m; i++){

       a[i] = new int[n];

   }

   cout<<"Вводите элементы: "<<endl;

   for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           cin>>a[i][j];

       }

       cout << endl;

   }

     for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           cout<<a[i][j]<<"  ";

       }

       cout << endl;

   }

   cout << "" << endl;

///

   int tmax,tmin,t;

   for(int j=0; j<n; j++)

   {

       tmin=0;

       tmax=0;

       for(int i=0; i<m; i++)

       {

           if(a[i][j]<a[tmin][j]) tmin=i;

           if(a[i][j]>a[tmax][j]) tmax=i;

       }

       t=a[tmin][j];

       a[tmin][j]=a[tmax][j];

       a[tmax][j]=t;

   }

///

   for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           cout << a[i][j] << "  ";

       }

       cout << endl;

   }

for (int i = 0; i <m; i++)

delete[]a[i];

delete[]a;

   system("pause");

   return 0;

}

Там как-нибудь перепиши в c# они похожи

0,0(0 оценок)
Ответ:
Evgen2100zzz
Evgen2100zzz
19.01.2020 02:09

Лента в Microsoft Word позволяет максимально быстро получить доступ к наиболее часто используемым командам. Лента содержит огромное количество команд, которые разбиты по смысловым группам. В этом уроке Вы узнаете, из каких вкладок состоит Лента, а также научитесь скрывать ее, чтобы увеличить рабочую область Word на экране монитора.

Если Вы ранее пользовались Word 2010 или 2007, тогда Word 2013 покажется Вам знакомым. В нем используются все те же Лента и Панель быстрого доступа, где можно найти команды для наиболее часто используемых задач, а также представление Backstage.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота