В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
byxanceva6kv2
byxanceva6kv2
22.12.2021 00:05 •  Информатика

Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется при умножении на 2,3,4,5,6,7,8 и 9 (например, число 9). Используйте функцию для вычисления суммы цифр числа.


Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется

Показать ответ
Ответ:
rizhik68
rizhik68
23.01.2021 10:09

def smm_numbers(x):

  sm = 0

  sm_num = 0

  for _ in x:

      sm += int(_)

  for j in range(2, 10):

      j = str(j * int(x))

      for p in j:

          sm_num += int(p)

      if sm_num != sm:

          return False

      sm_num = 0

  return True

a, b = map(int, input().split())

count = 0

for i in range(a, b + 1):

  if smm_numbers(str(i)):

      print(i)

      count += 1

if count == 0:

  print(0)

Объяснение:

соблюдайте отступы что бы избежать синтаксической ошибки

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота