В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
jungkook010997
jungkook010997
12.02.2020 05:42 •  Информатика

Напишите программу, которая находит все символы в символьной строке, которые встречаются только один раз. входные данные на вход программы подаётся символьная строка. выходные данные программа должна вывести все символы, которые встречаются в строке только один раз, в порядке возрастания их ascii-кодов. если таких символов нет, нужно вывести слово 'no'. примеры входные данные asd12ad2 выходные данные 1s pascal abc 1.8 с использованием множеств

Показать ответ
Ответ:
kristinasaib1
kristinasaib1
02.08.2020 21:28
Var uniq: Set of Char;
    used: Set of Char;
    s: string;
    i: integer;
    done: boolean;
    c: char;
begin
uniq := [];
used := [];
readln(s);

for i := 1 to length(s) do
  if not (s[i] in used) then
  begin
    include(uniq, s[i]);
    include(used, s[i]);
  end
  else
  begin
    exclude(uniq, s[i]);
  end;

done := False;
for c := #0 to #255 do
  if (c in uniq) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write('NO');

writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота