В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ULYA1111111
ULYA1111111
11.11.2022 07:08 •  Информатика

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольника. напишите программу так чтобы любое число могло быть гипотенузой. паскаль

Показать ответ
Ответ:
FoxyzSuper
FoxyzSuper
08.10.2020 20:51
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger('Введите стороны прямоугольника',3).Sorted.ToArray;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Могут')
  else Writeln('Не могут')
end.

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота