В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
mketol4663
mketol4663
05.08.2022 12:03 •  Информатика

Напишите программу, которая определит какой процент состовляют буквы "а" во введеном тексте. ВНИМАНИЕ ЭТО НА C++, НЕ Pascal ​

Показать ответ
Ответ:
Кристиночка2003
Кристиночка2003
19.11.2022 04:48
PYfy9pX4YibdfKzE8dnbSXaP3D5sbZenWQXx+TzottBxmrnKP4dS39zDFCHeytaxQuaxO6+SihcUhSqF6PmmxN3GxGIIAPLiSxjqjTtSHbvo7htEBwkC9DrKA9nK9xIOxPRcjpd6DAdMG0SkqPbK1+57wXgl2KsD43bDyI91iNHZGVEFuJjW2WjoZmDZOb/rVd7R9AqyWfNwqgLu5n0s8oZKpT55zvtPlOdDo6CM93h3C9G55Qj17fBXO/NNywpSzMGUqCxZha8Dm9QprL4Amawdo2pnCyu31Kn+Zny692acWR8k+IjeIoeL9HS7GGpxomAYoUcl2QOl2meKVWiovxtHmLKNooQK1Hc8yqvu293YHqgzQp3rHNgJxPJfiQnUmlYXGvOGZLk6vEUXIiesvdftDsCS/8Ae6YiLr8HWExGez9YXrworoX46BqS86+EFy3m8zwgu1fA9z61qLUP90KYw8KxlJJDWAThAVGrADHEsoHJ35+216/jwx5ruS3xgPOL83Vy5P1bL884jUiefVsuhprgR7C75lvy2ZCUYolQ=
0,0(0 оценок)
Ответ:
121517
121517
01.06.2023 19:36
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота