В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
denchik20041
denchik20041
01.03.2022 03:18 •  Информатика

Напишите программу, которая определит количество предложений в тексте. предложение заканчивается одним из трёх символов: «.», «? », «! ». предполагается, что в тексте есть хотя бы одно предложение.​

Показать ответ
Ответ:
Викуся084
Викуся084
05.04.2020 15:47
Думаю, что-то типа того.

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    const int n = 100;
    char *C = new char[n];
    int p // позиция
    int l // длина
    int k // повторения

    cout << "String C: ";
    cin >> C;
    cout << "Pos: ";
    cin >> p; p--;
    cout << "Length: ";
    cin >> l;
    cout << "N: ";
    cin >> k;
    char *V = new char[l*k+1];

    if ((p >= 0) && (l > 0) && (k > 0) && ((strlen(C) - p) >= l) && (p <= strlen(C))) //проверка ввода
    {
        __asm
        {
            mov ebx, k;           // количество повторений
            mov edi, V         // адрес приёмника
            m1 : cmp   ebx, 0  // сравнение
                 je   exit1    // если EBX = 0, то переход на exit1
                 mov   ecx, l  // длина строки
                 mov   esi, C  // адрес источника
                 add   esi, p  // с заданной позиции
             m2 :
                mov al, [esi]    //из ESI
                mov [edi], al    // запись в EDI
                inc edi            // EDI+1
                inc esi            // ESI+1
                loop  m2        // цикл EСХ раз
                dec ebx         // EBX-1
                jmp m1             // переход на m1
            exit1 : mov[edi], 0
        }

        cout << "\nV: ";
        cout << V << endl;
    }

    else cout <<  "\nError " << endl;

    system("pause");
}
0,0(0 оценок)
Ответ:
mikhalyukmahem
mikhalyukmahem
28.02.2023 19:13
Для решения всех задач используется формула S = v*t, где S - объем файла, v - скорость передачи файла, t - время передачи.
1. 
4 Мбайта = 4*1024 Кбайт = 4096 Кбайт
S1 = v*t1, S2 = v*t2
S2 = (S1/t1)*t2 = (4096/100)*75 = 3072 Кбайт

2.
8 Мбайт = 8*1024 Кбайт = 8192 Кбайт
S1 = v*t1, S2 = v*t2
S2 = (S1/t1)*t2 = (8192/100)*25 = 2048 Кбайт

3.
15 Кбайт = 15*1024 байт = 15*1024*8 бит
S = v1*t1, S = v2*t2
v1 = S/t1, v2 = v1+512 = S/t1+512 = 15*1024*8/120+512 = 1536
t2 = S/v2 = 15*1024*8/1536 = 80 c

4.
S1 = v*t1, S2 = v*t2
2 мин = 120 с
t2 = S2/v = S2/(S1/t1) = 4/(3/120) = 160 с

5.
3 Мбайта = 3*1024 Кбайт = 3072 Кбайт
S1 = v*t1, S2 = v*t2
S2 = (S1/t1)*t2 = (3072/60)*40 = 2048 Кбайт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота