В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ggix
ggix
24.07.2021 20:33 •  Информатика

Напишите программу,которая определяет длину ведённой строки и подсчитывает количество букв «а»

Показать ответ
Ответ:
Krossmans111
Krossmans111
11.01.2021 04:46

Если паскаль абс

program v1;

var st1:string;

   i,L:Integer;

   numA:Integer;

begin

   write('text: ');

   readln(st1);

   L := Length(st1);

   numA := 0;

   for i:=1 to L do begin

       case st1[i] of

           'А','а': numA:=numA+1; //rus

           'A','a': numA:=numA+1; //eng

       end;

   end;

   st1 := UpperCase(st1);

   writeln('Dlina stroki ',L);

   writeln('kol-vo A  ',numA);

end.


Напишите программу,которая определяет длину ведённой строки и подсчитывает количество букв «а»
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота