В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Асемаmail
Асемаmail
17.03.2022 22:31 •  Информатика

Напишите программу, которая определяет, есть ли среди цифр числа X цифра Y. X и Y вводятся с клавиатуры (например если введем с клавиатуры 2368 и 5 то программа должна вывести на экран " в числе 2368 цифра 5 отсутствует",
или если мы введем с клавиатуры 8736 и 7, то программа должна вывести на экран " в числе 8736 цифра 7 присутствует"

Показать ответ
Ответ:
barbara27
barbara27
25.02.2023 17:30
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
0,0(0 оценок)
Ответ:
Lera246hh
Lera246hh
28.03.2023 12:15

1.

#include <iostream>

#include <vector>

using namespace std;

int main(){

int a,b;

cin>>a;

vector<int> v1;

vector<int> v2;

for(int i=0; i<a; i++){

cin>>b;

if (b%2==0) v1.emplace_back(b);

else v2.emplace_back(b);

}

sort(v1.begin(), v1.end());

sort(v2.begin(), v2.end());

for(auto & i: v1) cout<<i<<" ";

}

2.

#include <iostream>

#include <vector>

using namespace std;

int main(){

vector<float> v;

//здесь нам задают массив

sort(v.begin(), v.end());

cout<<v[0]<<v.back();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота