В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
violettaratonina
violettaratonina
29.06.2021 06:50 •  Информатика

Напишите программу которая определяет находится ли введеный год в настоящем или будущем (работа в паскале )

Показать ответ
Ответ:
tima3002
tima3002
06.10.2020 14:33
Const    current_year = 2017;

var    year: integer;

begin

    readLn(year);

    if year < 2017 then 



    else if year = 2017 then 

        Write(year, ' настоящее')

    else if year > 2017 then 

        Write(year, ' будущее')

end.
0,0(0 оценок)
Ответ:
Никk
Никk
06.10.2020 14:33
Проблем быть не должно, думаю, это самое примитивное.
Program asd;
Var x: integer;
Begin
read(x);
if x<2017 then Write(' — ',x,' год уже
if x=2017 then Write(' — ',' Сейчас — ',x,'.') else
if x>2017 then Write(' — ',x,' Еще не настал.')
end.

Надеюсь
Буду благодарен, если выберешь "Лучший"
Удачи!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота