В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
doroxova04
doroxova04
14.02.2020 23:56 •  Информатика

Напишите программу которая определяет nod трех натуральных чисел (с использованием процедур)

Показать ответ
Ответ:
pankewitchkati
pankewitchkati
03.07.2020 08:46
Var
 a,b,c:integer;
procedure main(a,b,c:integer);
var
 i,max,nod:integer;
begin
 if (a>b) and (a>c) then
  max:=a
 else
  if (b>a) and (b>c) then
   max:=b
  else
   max:=c;
 nod:=1;
 for i:=1 to max do
 begin
  if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
   nod:=i;
 end;
 writeln(nod);
end;
begin
 read(a,b,c);
 main(a,b,c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота