В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ilyakuhs228
Ilyakuhs228
30.07.2022 01:25 •  Информатика

Напишите программу, которая определяет сколько раз встречается максимальное число в и-той последовательности, ограниченная n значением. при этом каждое вводимое число должно храниться в памяти компьютера.

Показать ответ
Ответ:
leonovapodkina
leonovapodkina
07.10.2020 08:10
//Pascal
var
  A: array of integer;
  i, n, MAX, tmpCount: integer;
begin
  write('Введите n = '); read(n);
  SetLength(A, n);
  MAX := 0;
  for i := 0 to n-1 do
  begin
    write('A[', i+1, '] = ');
    read(A[i]);
    if A[i] > MAX then
    begin
      tmpCount := 0;
      MAX := A[i];
      tmpCount := tmpCount + 1;
    end
    else
    if A[i] = MAX then tmpCount := tmpCount + 1;
  end;
  writeln('Максимальное число ',MAX,' встречается ',tmpCount,' раз.'); 
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота