В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
aruzhaan2003
aruzhaan2003
25.09.2022 00:42 •  Информатика

Напишите программу,которая: определяет,сколько раз встречается в строке символов 'a'; заменяет символ 'a' символом '*'

Показать ответ
Ответ:
otegenovaaina2
otegenovaaina2
08.10.2020 04:14
Поставил на проверку русскую "а", если нужно английскую поменяйте в строчке с if

var a:string;
i,count:integer;
begin
writeln('Введите предложение;');
read(a);
for i:=1 to length(a) do begin
if (a[i]='а') or (a[i]='А') then begin
count:= count + 1;
a[i]:='*';
end;
end;
write(count);
writeln(' раз встречается буква а.');
writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота