В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
irochkaneznano
irochkaneznano
06.01.2022 04:19 •  Информатика

Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом

Показать ответ
Ответ:
0121090066
0121090066
08.10.2020 07:30
Выводит YES если есть, и NO если нету
На языке С++:

#include <bits/stdc++.h>
using namespace std;

string s;

int main ()
{
cin >> s;
for (int i = 0; i < s.size(); ++ i)
{
for (int j = i; j < s.size(); ++ j)
{
int a = s[i] - '0';
int b = s[j] - '0';
if (a == b)
{
cout << "YES";
return 0;
}
}
}
cout << "NO";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота