В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Lora20060
Lora20060
31.08.2022 14:16 •  Информатика

Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа

Показать ответ
Ответ:
amrah555
amrah555
25.08.2020 16:20
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота