В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
hgcfm
hgcfm
28.12.2022 12:55 •  Информатика

Напишите программу, которая определяете произведение кубов четных чисел от 5 до 100​

Показать ответ
Ответ:
tenoruk77
tenoruk77
21.02.2021 18:43

Оператор mod возвращает остаток от деления. Четное число – такое, остаток от деления которого на 2 равен нулю.

Функция int возвращает целую часть дробного числа. С её можно реализовать mod (\texttt {a mod b} – примерно то же самое, что и \texttt{a - b * int(a / b)}) или сравнить результат умножения на 2 целой части результата деления исходного числа на 2 с исходным числом.

Код:

begin

   var a := ReadInteger();

   writeln(a mod 2 = 0);

   writeln(a - 2 * int(a / 2) = 0);

   writeln(a = 2 * int(a / 2));

end.


Пример ввода:

5

Пример вывода:

False

False

False


Пример ввода:

42

Пример вывода:

True

True

True

0,0(0 оценок)
Ответ:
poseido2008p04tk8
poseido2008p04tk8
15.11.2022 06:20

Системный блок - в нём располагаются внутренние узлы персонального компьютера;

Монитор - позволяет вывод данных: текстов, изображений и другой информации;

Клавиатура - служит для ввода информации;

Мышь - хоть при её можно управлять работой компьютерных программ.Системный блок - в нём располагаются внутренние узлы персонального компьютера;

Мышь не обязательная если у вас ноутбук.

Корпус системного блока - внешний вид компьютера

Системная (материнская) плата - к ней подключаются кабели и оперативная память.

Оперативная память - необходима для хранения временных данных,

Процессор - выполняет большинство вычислительных задач.

Видеокарта - графическая плата, выводит на монитор информацию.

Жёсткий диск - возможен для длительного хранения данных.

Блок питания - без него не запустится компьютер, обеспечивает системный блок электричеством.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота