В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
343463165313
343463165313
01.12.2021 22:43 •  Информатика

Напишите программу, которая переводит число в 10-й с/с в 2-ую с/с через цикл while.

Показать ответ
Ответ:
veronikadasha8
veronikadasha8
25.04.2021 14:30

#include "stdafx.h"

#include <iostream>

using namespace std;

 

int main() {

   setlocale(LC_ALL, "Russian");

   int n;

   cout << "Введите число" << endl;

   cin >> n;

   while (n > 0) {

   (n%2 == 0) ? cout << "0" : cout << "1";

   (n%2 == 0) ? n = (n) / 2 : n = (n-1) / 2;  

   }

   cout << endl;

   system("pause");

   return 0;

}

var ch,new,st_10:integer;

begin

 writeln('Введи число');

 readln(ch);

 st_10:=1;

 while ch<>0 do

 begin

  new:=new+(ch mod 2)*st_10;

  ch:=ch div 2;

  st_10:=st_10*10;

 end;

 writeln('Число в двоичной системе сч.- ',new);

end.

Объяснение:

1)язык c++, 2) Паскаль, поставь лайк )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота