В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ivanova329
ivanova329
01.03.2020 00:56 •  Информатика

Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. входные данные входная строка содержит шестнадцатеричную запись числа n ( 1 ≤ | n | < 10 9 ). выходные данные программа должна вывести десятичную запись этого числа.

Показать ответ
Ответ:
0Mishaj
0Mishaj
08.10.2020 10:49
#include <iostream>
using namespace std;
int main()
{
    int N;
    setlocale(LC_ALL, "Russian");
    cin >> hex >> N;
    cout << N << endl;
    system("pause");
    return 0;
}

Пример:
27A9A
162458
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота