В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
novoselovavita
novoselovavita
06.05.2023 14:26 •  Информатика

Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

Показать ответ
Ответ:
filimonovajulia1
filimonovajulia1
02.10.2020 08:30
Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)

var  a: integer;
begin
  read(a); 
 if (a > 5) and (a <= 11) then
    write('Утро ');
 if (a > 11) and (a <= 17) then
    write('День ');
 if (a > 17) and (a <= 23) then
    write('Вечер'); 
 if (a = 24) or (a < 6) then 
    write('Ночь');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота