В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
WESTBEST
WESTBEST
08.12.2020 09:48 •  Информатика

напишите программу которая подсчитывает количество цифр в натуральном числе N введённым с клавиатуры​

Показать ответ
Ответ:
riathome26
riathome26
15.11.2020 10:09

#include <iostream>

using namespace std;

typedef long long ll;

int main()

{

  ll number, i = 0;

  cin >> number;

  while(number > 0){

      number/=10;

      ++i;

  }

  cout << i;

}

// хитрый вариант с использованием строк на случай если число будет очень большое

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string number;

  cin >> number;

  cout << number.size();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота