В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Skaikill
Skaikill
31.08.2020 11:08 •  Информатика

Напишите программу, которая получает два целых числа (a и b) и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. питон

Показать ответ
Ответ:
m8756m
m8756m
10.10.2020 13:31

a,b = map(int,input().split())

neg = bool()

zero = bool()

i = int()

ab = int()

if a==0 and b==0:

   zero = True

if not(zero):

   for i in range(abs(a)):

       ab += b

   

if a<0 and not(zero):

   print(ab*-1)

elif zero:

   print(0)

else:

   print(ab)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота