В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Abbal
Abbal
23.08.2021 14:28 •  Информатика

Напишите программу, которая получает на вход числа а и в, а так же число х. если х =1, то вывести сумму первых двух чисел, если х=2, то разность. программа должна вывести число, а так же словесное описание, какая операция была выбрана.

Показать ответ
Ответ:
Вероника1306
Вероника1306
05.08.2020 13:52

Предоставляю программу на языке Pascal!

var

A, B, X: integer;

begin

readln (A, B, X);

if (X = 1) then write (A+B, ' - сумма')

else if (X = 2) then write (A-B, ' - разность');

end.

0,0(0 оценок)
Ответ:
Dan4ikFun4ik
Dan4ikFun4ik
05.08.2020 13:52

PascalABC.NET

begin

 var (a, b, x) := ReadInteger3;

 if x = 1 then

   Print('Сумма', a + b)

 else if x = 2 then

   Print('Разность', a - b)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота