В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kittikatlove
kittikatlove
05.01.2020 10:06 •  Информатика

Напишите программу, которая получает номер месяца и выводит соответствующее ему время года или сообщение об ошибке.
пример:
введите номер месяца:
5
весна
пример:
введите номер месяца:
15
неверный номер месяца.
решить в python 3.7.1. примерно так, как на фотографии. (я сама ничего не знаю, может, там фигня) ​

Показать ответ
Ответ:
Uvarovakatya200
Uvarovakatya200
08.07.2021 02:20
Var
   a,b,d,K,kp:integer;
   P:boolean;
Begin
kp:=0;
ReadLn(a,b);
if (a = 1)or(a = 2) then
   Begin
   kp:=2;
   Write(2,' ',3)
   end
else if a = 3 then
        Begin
        kp:=1;
        Write(3);
        End;
if a < 5 then a:=5
else if a mod 2 = 0 then a:=a+1;
While a<=b do
   Begin
   K:=Trunc(Sqrt(A));
   d:=3;
   P:=true;
   While d <= K do
      Begin
      if A mod d = 0 then P:=false;
      d:=d+2
      End;
   if P then
      Begin
      kp:=kp+1;
      Write(' ',a);
      End;
   a:=a+2
   End;
if kp = 0 then Write(0)
End.
0,0(0 оценок)
Ответ:
FSoxGy
FSoxGy
25.02.2023 15:15

===== PascalABC.NET =====

begin

 var n := ReadInteger('n =');

 var p := 1 - 1 / 2;

 var i := 3;

 while i <= n do

 begin

   p *= 1 - 1 / i;

   i += 1

 end;

 Println(p)

end.

Объяснение:

Хороший "страдать фигней", программируя подобные задачи.

Ведь понятно, что (1 - 1/2) (1 - 1/3) ( 1 - 1/4) ... (1 - 1/n) всегда равно 1/n

В самом деле? 1/2 × 2/3 × 3/4 × 4/5 × ... (n-1)/n = 1/n, потому что соседние члены взпимно сокращаются.

Правда, задав достаточно большое n, можно убедиться, что арифметика вещественных чисел небезупречна в точности. В приведенном примере для n = 2 миллиарда получаем погрешность уже в 13-й цифре.


Циклические алгоритмы с предусловием : дано натуральное число n. вычислить p=(1-1/2)(1-1/-1/n), где
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота