В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
TheLaikerMap
TheLaikerMap
09.11.2021 21:52 •  Информатика

Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическое всех чисел из отрезка [a; b], которые делятся на 3.
программа на питоне

Показать ответ
Ответ:
lolopoo
lolopoo
28.08.2021 14:55

from statistics import mean

a = []

for i in range(int(input('a = ')), int(input('b = ')) + 1):

   if i % 3 == 0:

       a += [i]

print('Ср. арифм. всех чисел:', mean(a))


Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическ
0,0(0 оценок)
Ответ:
Martina17
Martina17
28.08.2021 14:55

a=int(input())

b=int(input())

mas=[i for i in range(a,b+1) if i%3==0]

print(sum(mas)/len(mas))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота