В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма Евклида. Программа должна подсчитать количество шагов цикла. С

Показать ответ
Ответ:
huxgehd
huxgehd
15.10.2020 11:11

#include <iostream>

using namespace std;

int NOD(int a, int b) {

   

   int iter = 0;

   if (a < b) {

       swap(a, b);

   }

   while (a % b != 0) {

       a = a % b;

       swap(a, b);

       iter++;

   }

   cout<<"NOD: "<< b << " Iteration: "<< iter;

}

int main()

{

   int a,b;

   cin>>a>>b;

   NOD(a,b);

   return 0;

}


Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота