В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
qwerty06151
qwerty06151
08.01.2021 21:21 •  Информатика

Напишите программу, которая позволит проверять пароль на сложность.
Проверку пароля следует проводить по таким критериям:
1. Длина: от 5 символов.
2. Буквы латинского алфавита в верхнем и нижнем регистре: A, a, Z, z.
3. Цифры: от 0 до 9.
4. Символы: @, #, %, &.
Рекомендации
Можете воспользоваться методом isnumeric() для проверки строки на наличие цифр. Метод isupper() позволяет
выполнить проверку букв в верхнем регистре, islower()
следует использовать для проверки нижнего регистра. В свою
очередь, isalpha() позволит определить символ в строке.

Показать ответ
Ответ:
sasharsm
sasharsm
09.10.2020 22:01

python

import string

lower = list(string.ascii_lowercase)

upper = list(string.ascii_uppercase)

digits = ['0','1','2','3','4','5','6','7','8','9']

characters = ['@', '#', '%', '&']

password = input('Введите пароль: ')

password_difficulty = 0

for i in lower:

 if i in password:

   password_difficulty += 1

   break

for i in upper:

 if i in password:

   password_difficulty += 1

   break

for i in digits:

 if i in password:

   password_difficulty += 1

   break

for i in characters:

 if i in password:

   password_difficulty += 1

   break

print(f'Сложность пароля: {password_difficulty}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота