В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
настя7096
настя7096
02.07.2020 16:40 •  Информатика

Напишите программу, которая позволяет пользователю загрузить слова из CSV, в случайном порядке показывает пользователю слово и перевод, позволяет добавить новые слова, позволяет сделать выгрузку в CSV. - Загрузка слов из CSV
- Случайный просмотр
-Добавление новых слов
- Выгрузка слов в CSV
- Exception

Показать ответ
Ответ:
genri5673
genri5673
12.04.2023 20:03
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 
 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт
0,0(0 оценок)
Ответ:
ArtSvet
ArtSvet
09.02.2021 21:46
//Я просто опишу метод записи матрицы
const n=100;
var ar:array of array of integer;
 ars:array of array of string;
 i:integer;
 
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
 i,j:integer;
begin;
for i:=1 to n do
 begin;
   for j:=1 to n do
    begin;
     ar[i,j]:=random(9);
     str(ar[i,j],ars[i,j]);
    end;
 end;
end;

procedure burning(ars:array of array of string);
var
 i,j:integer;
 t:text;
 begin;
  assign(t,'text.txt');
  rewrite(t);
  for i:=1 to n do
   begin;
    writeln(t,' ');
     for j:=1 to n do
      write(t,ars[i,j],' ');
   end;
 end;  

begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
 begin;
  setlength(ar[i],n+1);
  setlength(ars[i],n+1);
 end;
complection(ar,ars);
burning(ars);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота