В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Krisomanka01
Krisomanka01
04.03.2020 13:38 •  Информатика

Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. попробуйте ввести действительное число для числа знаков после запятой.

Показать ответ
Ответ:
kostaKOSTAkosta
kostaKOSTAkosta
09.10.2020 07:29

program Real2;

var

 a, b, d: Real;

 id: Integer;

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b);

 Write ('Введите число знаков после запятой: ');

 Read (d);

 id := Trunc (d);

 WriteLn;

 Write ('Сумма = ', a + b :15 :id);

 ReadLn;

 ReadLn;

end.

Объяснение:

действительное число для количества знаков после запятой вводится в d, затем чтобы использовать его в форматировании вывода преобразуется в целое (id := Trunc (d); ).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота