В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
leeesy664
leeesy664
11.08.2020 20:26 •  Информатика

Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится. результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением.

Показать ответ
Ответ:
ENOT234u
ENOT234u
02.10.2020 15:15
На паскаль
var i,j,k:longint;
begin
read(i);
if i < 10 then write('Число меньше 10. Поэтому оно не имеет двузначный делитель');
for j:=10 to 99 do
if i mod j=0 then inc(k);
if k=0 then write('Ваше число не имеет двузначный делитель') else write('Ваше число имеет ',k,' делителей');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота