Напишите программу, которая рисует концентриче-
ские окружности с центром в середине графического
окна. радиус самой маленькой окружности — 10 пик-
селей. разница радиусов — 20 пикселей. используйте
изменение интенсивности какого-либо цвета (или двух
одновременно) для заливки кругов.
Первая строка - разряды, т.е показатели степени двойки.
Вторая - значения степеней двойки, например, 2^8=256
В третьей строке делаем вычисления.
Записали исходное число 994. Смотрим ближайший разряд - девятый - там 512.
994>512, значит такая степень двойки в числе 994 содержится. Пишем в девятом разряде следующей строки 1, а рядом с 994 (в 9 разряде пишем остаток 994-512=482.
Повторяем процесс. В 8 разряде записано 256. 482>256. Снова 1 в четвертую строку и разность 482-256=98 в соседний, 7 разряд.
Так продолжается, пока не дойдем до 5 разряда. У нас там число 2, а в соседнем разряде 16. 2>16, поэтому разряд пропускаем, а в 4й строке пишем ноль. Так поступаем, пока не придем в разряд 1. 2=2, поэтому делаем вычитание, пишем 1 в 4ю строку, а в третьей пишем, как всегда, разность 2-2=0. Все. Остальные разряды четвертой строки заполняем нулями.
Двоичное представление числа - это 4-я строка.
994₁₀ = 111110010₂
В ЯП Pascal, массивы, как и другие переменные, задаются в блоке var:
var
array_name: array [a..b] of data_type;
array_name - имя переменной
a, b - первый и последний индексы массива
data_type - тип данных элементов (char, string, integer, ...)
После задания массива, вы можете обращаться к его элементам в программе с
array_name[k]
где k - целое число между а и b, индекс элемента
Пример кода:
var a: array [1..2] of integer;
begin
a[1] := 5;
a[2] := 10;
writeln(a[1] + a[2]);
end.
Вывод: 15