В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sanya3344
sanya3344
12.09.2021 23:43 •  Информатика

Напишите программу, которая считывает 5 целых чисел, каждое на одной строке записывает их в массив и печатает этот массив наоборот на одной строке через пробелы. Использовать функции (readln, write, for downto). Пример Ввод

1

2

3

4

5

Вывод

5 4 3 2 1

Показать ответ
Ответ:
tawawma
tawawma
22.12.2020 19:57

program z1;

var i: integer;

a:array [1..5] of integer;

begin

for i := 1 to 5 do readln (a[i]);

for i := 5 downto 1 do write (a[i],'  ')

end.

Объяснение:

Цикл со счётчиком:

for i := a to b do, где a <= b (от меньшего к большему)

for i := a downto b do, где a >= b (от большего к меньшему)

readln - ввод следующей строки с новой строки

write - вывод следующей строки с этой же строки

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота