В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LONNI34
LONNI34
24.02.2021 08:33 •  Информатика

напишите программу ,которая считывает два целых числа a и b и выводит на экран квадрат суммы (a+b)^2 и сумму квадратов a^2 + b^2 этих чисел (python )

Показать ответ
Ответ:
coolmeen
coolmeen
16.02.2021 13:15
1)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i+j>5) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.

2)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i>J) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.
0,0(0 оценок)
Ответ:
rrus2057
rrus2057
14.04.2021 22:33
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,n,i,s:integer;
begin
  write('Число элементов последовательности ');
  readln(n);
  for i:=1 to n do begin
    write(i,' элемент последовательности = ');readln(a);
    if (a mod 2 <>0) then s:=s+a;
  end;
  writeln('Сумма нечетных = ',s);
 end.

Тестовое решение:
Число элементов последовательности 5
1 элемент последовательности = 3
2 элемент последовательности = 2
3 элемент последовательности = 4
4 элемент последовательности = 1
5 элемент последовательности = 5
Сумма нечетных = 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота