В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Olyaaa4Kaaaa
Olyaaa4Kaaaa
03.02.2023 05:26 •  Информатика

Напишите программу, которая считывает одно натуральное число и выводит на первой строке все делители этого числа порядке возрастания, разделенные пробелами, а на второй "ПРОСТОЕ" или "НЕТ" в зависимости от того, простым было введеное число или нет

Показать ответ
Ответ:
swietajakubiak
swietajakubiak
10.01.2021 14:47

digit=int(input('Введите число:\n'))

delit=1

spisok_del=[]

while delit <= digit:

   if digit % delit == 0:

       spisok_del.append(delit)

   delit+=1

for i in spisok_del:

   print(i,end=' ')

if len(spisok_del)==2 and max(spisok_del)==digit:

   print('\nПростое')

else:

   print('\nНет')

Объяснение: язык программирования - Python

0,0(0 оценок)
Ответ:
спартак371
спартак371
10.01.2021 14:47

n = int(input("Введите число: "))

deliteli = [num for num in range(1, int(n**0.5)) if not(n % num)]

deliteli += [n // delitel for delitel in deliteli[::-1]]

print(*deliteli, sep=', ')

print(f"{"простое" if deliteli == [1, n] else "нет"}")

Объяснение:

Нет смысла проверять числа до считываемого числа, остальные можно посчитать

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота