В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mashkabaku
mashkabaku
15.03.2022 18:59 •  Информатика

Напишите программу, которая считывает одну строку, после чего выводит «Да», если в введённой строке есть слово «золото», и «Нет» в противном случае.

Показать ответ
Ответ:
angel20062006
angel20062006
04.11.2021 05:00
1. Первая цифра отводится на знак (1 - это -, 0 - это +). Остальные 7 - число в двоичной системе счисления. Причём если число отрицательное, то исходное двоичное число инвертируется, и к нему прибавляется 1.
а) 33 | 16 | 8 | 4 | 2 | 1 - в двоичной системе оно выглядит как 100001
      1 |  0  | 0 | 0 | 0 | 1
Так как оно положительное, то в начале ставится 0. Так как чисел всего 6, а не 7, то после первого нуля следует поставить ещё один.
ответ: 0'0100001
б) -63₁₀ = -111111₂ (переводить уже не буду подробно)
Так как число отрицательное, то в начале ставим 1, так как цифр 6, то ставим после 1 0.
1'0111111
Инвертируем:
1'1000000
Прибавляем 1:
1'1000001
ответ: 1'1000001
в) -254₁₀ = -11111110
Так как цифр 8, то последнюю отбрасываем, а далее по алгоритму:
1'1111111 >> 1'0000000 >> 1'0000001
ответ: 1'0000001

2.' ' '                   . . . . .
а) 11110  б)  10101010
   + 1101     -       11011
=101011     =10001111
в)   1101
     *  101
      1101
+1101
=1000001
Всё, как в обычной арифметике.
0,0(0 оценок)
Ответ:
Dozie
Dozie
19.01.2023 13:21
#include <iostream>
using namespace std;
int main() {
        int mat[3][3];
        int k;
        int size=0;
        int * arr=0;
        for(int i=0;i<3;i++){
                for(int j=0;j<3;j++){
                       cin>>mat[i][j];
                          if (mat[i][j]>0){
                             arr=(int*)realloc(arr,sizeof(int)*(++size));
                             arr[size-1]=mat[i][j];
                                             }
                                           }
                                    }
                  for(int i=0;i<size;i++){
                  cout<<arr[i];
                  }
               delete arr;
               cin.get();
               cin.get();
              return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота