Напишите программу , которая считывала бы с клавиатуры данные о пяти призывниках (фамилия, имя, отчество, год рождения, заболевание) и выводила бы результат в виде таблицы на экран (считывание и сохранение данных должно производится в словарь) .
на pyhon
begin
Writeln('Температура апреля:');
var a:=ArrRandom(30,-10,10); a.Println;
var sr:=a.Where(x->x>=0).Average;
Writeln('Средняя температура для дней, когда >0 = ',sr:4:1);
var k:=a.Where(x->x>=0).Count;
if k=0 then writeln('No')
else Writeln('Количество дней с температурой >0 = ',k);
Writeln('Самая низкая температура: ',a.IndexMin+1,' день апреля');
end.
Пример:
Температура апреля:
-3 -5 9 7 0 -7 -3 8 -5 9 -5 1 -8 3 0 3 -2 -7 9 4 2 -4 -10 7 1 7 4 3 6 -2
Средняя температура для дней, когда >0 = 4.6
Количество дней с температурой >0 = 18
Самая низкая температура: 23 день апреля
var
a:array[1..n,1..m] of integer;
i,j,s,max,imax:integer;
begin
Randomize;
writeln('Зарплата за год:');
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(15000)+10000;
write(a[i,j]:6);
end;
writeln;
end;
writeln('Средние зарплаты по месяцам:');
max:=0;
for j:=1 to m do
begin
s:=0;
for i:=1 to n do s:=s+a[i,j];
write(s/n:5:2,' ');
if s>max then begin max:=s; imax:=j; end;
end;
writeln;
writeln('max = ',max/n:5:2,' месяц:',imax);
end.
Пример (для 4 месяцев, т.е. m=4):
Зарплата за год:
12533 11176 15153 14194
12649 22212 15546 17586
23643 15664 15538 21740
24382 10015 15816 24377
11388 12739 18790 21034
Средние зарплаты по месяцам:
16919.00 14361.20 16168.60 19786.20
max = 19786.20 месяц:4