В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Rairaku24
Rairaku24
22.10.2022 17:46 •  Информатика

Напишите программу, которая шифрует тексты следующим образом: исходная строка разбивается на части по 3 символа и эти три символа перемещаются по кругу вправо на одну позицию. если последняя группа символов состоит из 1 или 2 символов, то они остаются неизменными turbo pascal

Показать ответ
Ответ:
Viktor2017Kot
Viktor2017Kot
07.10.2020 03:44
Var s:string; c:char; i:integer;
begin
writeln('Введите строку:');
readln(s);
for i:=0 to length(s) div 3-1 do
 begin
 c:=s[3*i+3];
 s[3*i+3]:=s[3*i+2];
 s[3*i+2]:=s[3*i+1];
 s[3*i+1]:=c;
 end;
writeln(s);
end.

Пример:
Primer, begin, end.iPrrmeb, ieg n,den.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота