В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alexandro1888
Alexandro1888
14.05.2021 00:02 •  Информатика

Напишите программу, которая случайным образом выбирает дежурных: выводит два случайных числа в диапазоне от 1 до n, где n- количество учеников вашего класса. с какой проблемой вы можете столкнуться? нужно сделать в паскале. заранее !

Показать ответ
Ответ:
Alesandrenok
Alesandrenok
21.09.2020 09:38
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
var
  n,n1,n2:integer;
begin
  Write('Количество учеников: '); Read(n);
  Randomize;
  n1:=Random(n)+1;
  n2:=n1;
  while n2=n1 do n2:=Random(n)+1;
  Writeln('Номера дежурных: ',n1,', ',n2)
end.

Тестовое решение:
Количество учеников: 35
Номера дежурных: 2, 26
0,0(0 оценок)
Ответ:
axon11kot
axon11kot
21.09.2020 09:38
Var n,d1,d2:integer;
begin
  writeln('Укажите сколько человек в классе:');
  readln(n);
  Randomize;
  d1:=Random(1,n);
  d2:=Random(1,n);
  while d1=d2 do d2:=Random(1,n);
  writeln('Дежурными назначены: ',d1,' и ',d2);
 end.

цикл   while d1=d2 do d2:=Random(1,n); сделан, чтобы исключить возможность совпадения номеров (когда генератор случайных чисел одинаковые номера выдаст)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота