В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу , которая сортирует массив, а затем находит максимальное из чисел , встречающихся в массиве несколько раз. паскаль

Показать ответ
Ответ:
BlaBla1aquamarine
BlaBla1aquamarine
02.08.2020 23:52
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Sort(a);
  var v:=a.Last;
  var found:=False;
  for var i:=a.High-1 downto 0 do
    if a[i]=v then begin Writeln(v); found:=True; break end
    else v:=a[i];
  if not found then Writeln('В массиве нет дубликатов')
end.

Пример
n= 15
-13 11 1 -19 14 2 20 -15 14 -10 -15 8 4 -2 -13
14
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота