В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
stepvitalii
stepvitalii
11.09.2020 03:14 •  Информатика

Напишите программу, которая сортирует массив из n элементов по возрастанию и считает при этом количество произведённых перестановок
(нужно в паскале)

Показать ответ
Ответ:
katya99ov
katya99ov
25.10.2020 08:05

uses graphabc;

 

procedure drawlight(x, y, r : integer; c : color);

begin

  brush.color : = c;

  circle(x, y, r);

end;

 

begin

  randomize;

  var v : = random(1, 3);

  var(c1,c2,c3): =(clwhite,clwhite,clwhite);

  case v of

    1 : c1 : = clred;

    2 : c2 : = clyellow;

    3 : c3 : = clgreen;

  end;

  drawlight(window.center.x, window.height div 10 * 2, window.height div 7, c1);

  drawlight(window.center.x, window.height div 10 * 5, window.height div 7, c2);

  drawlight(window.center.x, window.height div 10 * 8, window.height div 7, c3);

end.

в паскале

0,0(0 оценок)
Ответ:
Zxcvbnm900
Zxcvbnm900
02.06.2023 19:37

pascalabc:

program f0rwardirop;

var r, x,y: real;

b: boolean;

begin

  writeln('*   alphaeus is   *');

  write('ok, введите r =');   readln(r);

  write('теперь введите х =');   readln(x);

  write('и, наконец, введите y =');   readln(y);

  if x> =0 then  

      if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then   writeln('точка (',x,',',y,') принадлежит закрашенной области')

      else   writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота