В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая сортирует массив «методом пузырька» и находит количество различных чисел в нем. Пример: Массив: 5 3 4 2 1 6 3 2 4. После сортировки: 1 2 2 3 3 4 4 5 6. Различных чисел: 5 Паскаль абц

Показать ответ
Ответ:
ванёк10062005
ванёк10062005
22.05.2023 08:51

15 Кбайт

Объяснение:

V = K * i, где  

V - информационный объём изображения (размер файла, содержащего изображение)

K - количество точек (пикселей)

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

N = 2^i, где  

N - количество цветов в палитре

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

^ - знак степени

Дано:

K = 160 * 128 = 20 480 пикселей

N = 64 цвета

Найти:

V

64 = 2^i

64 = 2⁶

i = 6 бит

V = 20 480 * 6 = 122 880 бит = 15 360 байт = 15 Кбайт

1 байт = 8 бит

1 Кбайт = 1 024 байт

0,0(0 оценок)
Ответ:
usenov777
usenov777
07.09.2022 15:37

1)

n = int(input())

m = int(input())

a = []

b = []

for i in range(n):

   c = int(input())

   a.append(c)

for i in range(m):

   c = int(input())

   b.append(c)

print(len(a), len(b))

2)

n = int(input())

m = int(input())

a = []

b = []

for i in range(n):

   c = int(input())

   if c not in a:

       a.append(c)

for i in range(m):

   c = int(input())

   if c not in b:

       b.append(c)

print(len(a), len(b))

3)

n = int(input())

a = []

for i in range(n):

   b = input()

   a.append(b)

b = input()

if b not in a:

   print('Всё верно')

else:

   print('Вы повторяетесь')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота