В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
микс111111
микс111111
18.06.2021 11:06 •  Информатика

Напишите программу, которая составит все возможные комбинации из цифр 3.4.5.6. и проверит каждую из этих комбинаций, является ли она точным квадратом

Показать ответ
Ответ:
rubon
rubon
11.10.2020 00:03

Объяснение:

var a,b,c,d:integer;

begin

for a:=3 to 6 do

   for b:=3 to 6 do

       for c:=3 to 6 do

           for d:=3 to 6 do  begin

           if (a<>b) and (a<>c) and (a<>d)  and (b<>c) and (b<>d) and (c<>d)  and (frac(sqrt(1000*a+100*b+10*c+d))=0) then

writeln(a,b,c,d);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота