Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Нетта771
02.07.2022 18:43 •
Информатика
Напишите программу которая сравнивает три числа и выводит произведение двух наименьших
Показать ответ
Ответ:
NeMaximilan
07.10.2020 02:09
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int GetMin(vector<int> arr, int &index)
{
int min = arr[0];
index = 0;
for (int i = 0; i < arr.size(); i++)
{
if (arr[i] < min)
{
index = i;
}
}
return arr[index];
}
int main()
{
vector<int> n;
n.resize(3);
cin >> n[0] >> n[1] >> n[2];
int i = 0;
int min1 = GetMin(n, i);
n.erase(n.begin() + i);
int min2 = GetMin(n, i);
cout << min1 * min2;
cin >> n[0];
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
daschkavolf
24.04.2021 01:58
с информатикой. Очень надо...
Weronika2017
02.12.2021 18:23
Дан массив из целых чисел x[1..5]. заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов....
Vainax
21.02.2022 00:18
Необходимо вычислить в Excel 870⋅62. Запись в MS Excel выглядит следующим образом:=870∗62870×62+870+62...
snezhanashikolai
20.12.2021 17:46
Необходимо вычислить в Excel 718⋅57. Запись в MS Excel выглядит следующим образом:+718+57=718∗57718×57...
KatyaBelchik12
03.07.2020 09:38
Основные составляющие программного обеспечения ... A языки программирования и компьютерные вирусы B инструментальные средства и системное ПО C компилятор и интерпретатор...
tryfest
14.01.2022 23:15
по информатике 8й класс 1)Переведите максимальное трехзначное восьмеричное число в десятичную систему счисления. 2)Выполните сложение двух чисел 547 и 341. ответ запишите...
viktoria20000000
11.06.2021 04:52
Оперативная память необходима для ... A Хранения неизменной информации B долго хранения информации C кратко хранения информации D удаления информации E долго хранения...
Abbabon
21.10.2021 14:28
Составить таблицу истинности: A V B Λ (٦DVE)...
итд4
17.01.2020 18:50
Написал программу, но не знаю как задать if по рисунку. Паскаль...
знайка56884
08.07.2020 22:22
За Геродотом на будівництві пірамід щодня працювало до 100 тисяч чоловік. Виснажлива праця призводила до загибелі, каліцтва тисяч єгиптян. Але нам невідомі випадки...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <algorithm>
#include <vector>
using namespace std;
int GetMin(vector<int> arr, int &index)
{
int min = arr[0];
index = 0;
for (int i = 0; i < arr.size(); i++)
{
if (arr[i] < min)
{
index = i;
}
}
return arr[index];
}
int main()
{
vector<int> n;
n.resize(3);
cin >> n[0] >> n[1] >> n[2];
int i = 0;
int min1 = GetMin(n, i);
n.erase(n.begin() + i);
int min2 = GetMin(n, i);
cout << min1 * min2;
cin >> n[0];
return 0;
}