В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ксения6538
ксения6538
22.12.2020 23:58 •  Информатика

Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)

Показать ответ
Ответ:
kirill880
kirill880
05.10.2020 04:24
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('ем',''); s.Println
end.

Пример
> земля- планета солнечной системы
зля- планета солнечной систы
0,0(0 оценок)
Ответ:
rafik14
rafik14
05.10.2020 04:24
// PascalABC.NET (версия 3.2, сборка 1363)

const
  RM = 'ем';
var
  c, n: char;
  seq: boolean := False;
  s: string := 'Земля - планета солнечной системы';
begin
  writeln(s);
  for var i := 1 to (length(s) -1) do
  begin
    c := s[i];
    n := s[i+1];
    if seq = True then
    begin
      seq := False;
      continue;
    end;
    if (c = RM[1]) and (n = RM[2]) then
    begin
      seq := True;
      continue;
    end
    else
    begin
      seq := False;
      write(c);
    end;
  end;
  write(s[length(s)]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота