В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Danila240899
Danila240899
15.08.2021 12:50 •  Информатика

Напишите программу, которая в последоательности натуральных чисел оределяет сумму всех чисел, кратных 6 и оканчивающтхся на 2. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел кратных 6 и оканчивающихся на 2. вводные данные 12, 24, 22, 72, 11, 0. выходные данные 84 !

Показать ответ
Ответ:
Luka2015
Luka2015
26.08.2020 11:57
Var A:byte;
    S:integer;
Begin
Repeat
Read(A);
if (A mod 6 = 0)and(A mod 10 = 2) then S:=S+A;
Until A = 0;
Write(S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота