В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
imhopro
imhopro
07.10.2020 16:41 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет их сумму и подсчитывает разность количества положительных и отрицательных чисел последовательности. Программа получает на вход количество числе и затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Про-грамма должна вывести два числа: сумму чисел и разность количества положительных и отрица-тельных чисел.

Показать ответ
Ответ:
vladawin2
vladawin2
15.01.2021 17:02

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n, m;

   cin >> n >> m;

   vector<vector<int>> matrix(n, vector<int>(m));

   for (int i = 0; i < n; i++)

   {

       for (int j = 0; j < m; j++)

       {

           cin >> matrix[i][j];

       }

   }

   vector<int> ans;

   for (int i = 0; i < m; i++)

   {

       int pr = 1;

       for (int j = 0; j < n; j++)

       {

           pr *= matrix[j][i];

       }

       ans.push_back(pr);

   }

   for (auto x : ans)

   {

       cout << x << " ";

   }

return 0;

}

Значения элементов матрицы вводятся с клавиатуры. В векторе ans лежит ответ.

0,0(0 оценок)
Ответ:
izeddin2002
izeddin2002
27.12.2021 16:23
1),2)

Массив имеет следующие свойства:

1)Массив может быть одномерным, многомерным или массивом массивов.2)Количество измерений и длина каждого из измерений задаются, когда создается экземпляр массива. Эти значения нельзя изменить во время существования экземпляра.3)Используемые по умолчанию значения числовых элементов массива равны нулю, и элементам ссылки присвоено значение NULL.4)В массиве массивов элементы являются ссылочными типами и инициализируются значением null.5)Массивы индексируются от нуля: массив с n элементами индексируется от 0 до n-1.6)Элементы массива могут иметь любой тип, в том числе тип массива.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота