В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
valera555132
valera555132
14.08.2022 01:37 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет количество четных отрицательных чисел. программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа не превышают 30 000. программа должна вывести одно число: количество четных отрицательнх чисел пример работы программы входные данные -17 2 -6 0 выходные данные 1 с

Показать ответ
Ответ:
vika2074
vika2074
06.10.2020 15:12
#include <stdio.h>
#include <stdlib.h>
#include <locale>

int main()
{
    setlocale(LC_ALL, "RUS");
    int count = 0;
    int n;
    for (int i = 0; i < 1000; i++)
    {
        printf("Введите число >> ");
        scanf("%d", &n);
        if (n == 0)
            break;
        if (n % 2 == 0 && n < 0)
            count++;
    }
    printf("%d", count);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота